
Blueprint Creator - Kurzanleitung

 Schnellstart: Lightweight Blueprint (nur URL)🚀

Für einfache Blueprints ohne Custom-Plugins/Themes

1. Blueprint Creator öffnen → WordPress Admin → Blueprint Creator
2. Auswahl treffen:

◦ Theme: Repository-Theme auswählen (z.B. Twenty Twenty-Four)
◦ Plugins: Nur WordPress.org Plugins auswählen
◦ Inhalte: Posts/Pages optional

3. Blueprint generieren → Button “Blueprint generieren”
4. Lightweight URL kopieren → Im grünen Info-Box erscheint die URL
5. Fertig! → URL teilen oder in Playground öffnen

Vorteile: Keine Dateien nötig, direkt teilbar, funktioniert sofort

Einschränkungen: Nur für WordPress.org Themes/Plugins, keine Custom-Dateien

Schritt-für-Schritt: Lightweight URL erstellen

Mit der Lightweight-URL kannst du eine komplette WordPress-Testumgebung mit Themes, 
Plugins und Beispielinhalten teilen – ganz ohne Datei-Download. So geht’s:

1. Blueprint Creator öffnen
◦ Im WordPress-Admin-Menü auf „Blueprint Creator“ klicken.

2. Theme auswählen
◦ Wähle ein WordPress.org-Theme aus (z.B. Twenty Twenty-Four). Eigene Themes 

sind für die Lightweight-URL nicht möglich.
3. Plugins auswählen

◦ Aktiviere die gewünschten Plugins (nur aus dem WordPress.org-Repository). Eigene 
Plugins sind für die Lightweight-URL nicht möglich.

4. (Optional) Quick Posts anlegen
◦ Im Tab „Quick Posts“ kannst du Demo-Inhalte hinzufügen (Titel, Inhalt, Post Type, 

Taxonomien etc.).
5. (Optional) Sprache, Titel, Beschreibung setzen

◦ Sprache, Website-Titel und Beschreibung können im Formular angepasst werden.
6. Lightweight-URL generieren

◦ Klicke auf „Blueprint generieren“.
◦ Die grüne Box „Lightweight URL“ erscheint mit der fertigen URL.

7. URL kopieren
◦ Klicke auf das Kopier-Icon oder den Button „URL kopieren“.

8. URL teilen oder im Playground öffnen
◦ Die URL kann direkt im Browser geöffnet oder an andere weitergegeben werden.
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Hinweise: - Die Lightweight-URL funktioniert nur mit offiziellen Themes/Plugins aus dem 
WordPress.org-Repository. - Eigene Dateien, Custom-Plugins oder -Themes werden nicht 
übernommen. - Die URL ist sofort lauffähig im WordPress Playground.

 Quick Posts: Schnell Demo-Inhalte erstellen⚡

Für einfache Test-Posts ohne WXR-Export

Was sind Quick Posts?

Quick Posts ermöglichen es, Demo-Inhalte direkt im Blueprint zu erstellen, ohne einen 
kompletten WXR-Export zu benötigen. Ideal für: - Schnelle Demos mit wenigen Test-Posts - 
Plugin-Präsentationen mit Beispiel-Daten - Custom Post Types testen - Taxonomien 
demonstrieren

Quick Posts erstellen:

1. Quick Posts Tab öffnen → Im Blueprint Creator
2. Post hinzufügen → Button “Neuen Post hinzufügen” klicken
3. Post-Details eingeben:

◦ Titel: z.B. “Mein Test-Post”
◦ Inhalt: Optional, Text oder HTML
◦ Post Type:

▪ Standard: post (Beitrag)
▪ Oder: Neuen Custom Post Type erstellen (siehe unten)

◦ Custom Fields: Optional, für Meta-Daten
◦ Taxonomien: Optional, Kategorien/Tags zuweisen

Custom Post Type erstellen:

Direkt im Quick Posts Interface:

1. Post Type Dropdown öffnen
2. Slug eingeben (z.B. event, portfolio, produkt)
3. Label eingeben (z.B. “Veranstaltung”, “Portfolio”, “Produkt”)
4. Button “Neu” klicken
5. Supports auswählen (Features des CPT):

◦  ✅ Title - Titel-Feld
◦  ✅ Editor - Inhalts-Editor
◦  ✅ Thumbnail - Beitragsbild
◦  ✅ Excerpt - Auszug
◦  ✅ Custom Fields - Benutzerdefinierte Felder
◦  ✅ Comments - Kommentare
◦  ✅ Revisions - Revisionen
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◦  ✅ Author - Autor
◦  ✅ Page Attributes - Seitenattribute

Der CPT wird automatisch: - Als mu-plugin registriert (customPostType-{slug}.php) - Im 
Blueprint als writeFile Step hinzugefügt - Im Playground sofort verfügbar

Custom Taxonomien erstellen:

Taxonomien für CPTs:

1. Bei einem Quick Post → Unter “Taxonomien”
2. Neue Taxonomie → Button “+Neue Taxonomie” klicken
3. Taxonomy-Slug eingeben (z.B. genre, kategorie)
4. Terms eingeben (kommagetrennt, z.B. Action, Drama, Comedy)

Die Taxonomie wird automatisch: - Als mu-plugin registriert (custom-taxonomy-
{slug}.php) - Mit dem Post Type verknüpft - Terms werden dem Post zugewiesen

Custom Fields hinzufügen:

Meta-Daten für Posts:

1. Bei einem Quick Post → Unter “Custom Fields”
2. Feld hinzufügen → Button “+Feld hinzufügen”
3. Feld-Name (z.B. location, price, date)
4. Feld-Wert (z.B. Wien, 49.90, 2025-12-25)

Bei Custom Fields wird automatisch: - Eine Metabox im CPT generiert (metabox-
{post_type}.php) - Felder als Input-Felder angezeigt - Werte beim Speichern gesichert

Beispiel: Event-Post mit CPT
1. Quick Post hinzufügen
2. Post Type: "event" erstellen (Label: "Veranstaltung")
3. Supports: Title, Editor, Custom Fields, Revisions
4. Titel: "WordPress Meetup Wien"
5. Custom Fields:
   - location: "Wien"
   - date: "2025-12-25"
6. Taxonomie: "eventcat" (Terms: "Meetup, WordPress")

Resultat im Blueprint:
{ 
  "steps": [ 
    {"step": "mkdir", "path": "/wordpress/wp-content/mu-plugins"}, 
    {"step": "writeFile", "path": "customPostType-event.php"}, 
    {"step": "writeFile", "path": "metabox-event.php"}, 
    {"step": "writeFile", "path": "custom-taxonomy-eventcat.php"}, 
    {"step": "runPHP", "code": "wp_insert_post(...) + 
wp_set_post_terms(...)"} 
  ] 
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} 

Vorteile von Quick Posts:

 ✅ Kein WXR-Export nötig - Schneller als kompletten Content-Export
 ✅ Lightweight-kompatibel - Funktioniert auch in Lightweight URLs
 ✅ CPT & Taxonomien - Automatische Registrierung als mu-plugins
 ✅ Custom Fields - Automatische Metabox-Generierung
 ✅ Sofort testbar - Im Playground direkt verfügbar

Einschränkungen:

 ⚠️ Für wenige Posts - Bei vielen Posts besser WXR-Export verwenden
 ⚠️ Keine Medien - Bilder/Dateien müssen separat hochgeladen werden
 ⚠️ Einfache Struktur - Für komplexe Relationen WXR nutzen

 Erweitert: Bundle Blueprint (mit Custom-Dateien)📦

Für Blueprints mit Custom-Plugins, Custom-Themes oder Medien

Schritt 1: Blueprint erstellen

1. Blueprint Creator öffnen
2. Custom-Inhalte auswählen:

◦ Theme-Tab: Custom Theme auswählen und aktivieren
◦ Plugins-Tab:

▪ Custom Plugins → Haken setzen (wird automatisch exportiert)
▪ Repository-Plugins (z.B. ACF, WooCommerce, Contact Form 7)

◦ Inhalte-Tab: Posts/Pages/Custom Post Types wählen
◦ Medien-Tab: Bilder/Dateien auswählen
◦ FSE Templates-Tab:

▪ Templates (Seitenvorlagen)
▪ Template Parts (Header, Footer)
▪ Navigation Menüs
▪ Global Styles
▪ Wiederverwendbare Blöcke

◦ Erweitert-Tab:
▪ WordPress-Einstellungen (Permalink-Struktur, Diskussion, etc.)
▪ Zusätzliche Benutzer anlegen
▪ PHP-Code ausführen
▪ WP-CLI Befehle
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Schritt 2: Bundle erstellen

3. Blueprint generieren → Button klicken

4. Bundle Base-URL eintragen (optional):
https://github.com/DEIN-USER/DEIN-REPO/blob/main/

5. Bundle erstellen → Button “Bundle erstellen”

6. Bundle-ZIP wird heruntergeladen (z.B. blueprint-bundle-1234567890.zip)

 Option A: Bundle auf GitHub hochladen📤

Voraussetzungen

• GitHub Account
• Repository erstellt
• GitHub File Uploader Plugin installiert (optional)

Methode 1: Via Playground Site Manager (empfohlen für schnelles 
Testen)

1. Bundle-ZIP entpacken (lokal auf deinem PC)
2. Playground öffnen: https://playground.wordpress.net
3. Site Manager öffnen → Oben rechts auf “Site Manager” klicken
4. Blueprint hochladen:

◦ Unter “Blueprint” → “Upload Blueprint”
◦ Entpackten Bundle-Ordner oder blueprint.json hochladen
◦ Alle ZIP-Dateien (Plugins, Themes, Medien) mit hochladen
◦ Alle XML-Dateien (WXR-Export) mit hochladen

5. Blueprint starten → “Start Site” klicken
6. Fertig! → Site läuft mit deinem Blueprint

Vorteile: Schnell, kein GitHub nötig, ideal zum Testen

Methode 2: Manuell auf GitHub hochladen

1. Bundle-ZIP entpacken (lokal auf deinem PC)
2. GitHub Repository öffnen → Zum Ordner navigieren
3. Dateien hochladen:

◦ blueprint.json

◦ Alle .zip Dateien (Plugins, Themes, Medien)
◦ Alle .xml Dateien (WXR-Export)

4. Commit → “Upload blueprint files”
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Methode 3: Automatisch (mit GitHub Uploader Plugin)

1. Einstellungen → Blueprint Creator → Einstellungen
2. GitHub-Daten eintragen:

◦ User/Organisation
◦ Repository
◦ Branch (z.B. main)
◦ Ordner (z.B. blueprints/)

3. Bundle-URL im Creator eintragen
4. “GitHub hochladen” Button klicken → Fertig!

Playground-Link:
https://playground.wordpress.net/?blueprint-url=https://github.com/USER/
REPO/blob/main/blueprint-bundle-XXXXXXXXXX.zip

 Option B: In Bibliothek speichern📚

Für lokale Verwaltung und Wiederverwendung

Blueprint speichern:

1. Nach Blueprint-Generierung:
◦ Button “In Bibliothek speichern” klicken

2. Titel & Beschreibung eingeben
3. Speichern → Blueprint erscheint in Bibliothek

Bibliothek im Admin verwenden:

• Menü: Blueprint Creator → Bibliothek
• Übersicht: Alle gespeicherten Blueprints mit Info-Boxen:

◦  🔗 Lightweight Blueprint (grün) = Nur URL, ohne Dateien
◦  📦 Blueprint Bundle (blau) = Mit Custom-Dateien

• Aktionen pro Blueprint:
◦  🚀 Playground öffnen → Direkter Link zum Testen
◦  📋 Link kopieren → URL in Zwischenablage
◦  ⬇️ Bundle herunterladen → ZIP-Datei herunterladen
◦  ✏️ Bearbeiten → Titel/Beschreibung ändern
◦  🗑️ Löschen → Blueprint entfernen

Shortcode für Frontend:

Auf Seiten/Beiträgen:
[blueprint_library] 

Was zeigt der Shortcode? - Alle öffentlichen Blueprints in Card-Layout - Info-Box: 
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Lightweight oder Bundle - Button “Im Playground öffnen” - Button “Bundle herunterladen” 
(falls vorhanden) - Responsive Design für alle Geräte

Beispiel-Verwendung: - Demo-Seite für Kunden - Plugin-Showcase - Theme-Vorlagen 
präsentieren - Öffentliche Blueprint-Sammlung

 Option C: Bundle-Dateien einzeln in Playground hochladen🎮

Alternative: Dateien manuell importieren (ohne Site Manager)

1. Bundle-ZIP entpacken (lokal)
2. Playground öffnen: https://playground.wordpress.net
3. Dateien hochladen:

◦ Plugins: Playground → Plugins → “Add New” → Upload
▪ Jede Plugin-.zip einzeln hochladen

◦ Themes: Appearance → Themes → “Add New” → Upload
▪ Theme-.zip hochladen

◦ Medien: Media → “Add New” → Upload
▪ media-XXXXX.zip entpacken und Dateien hochladen

◦ Posts/Pages: Tools → Import → WordPress
▪ export-content-XXXXX.xml importieren
▪ export-fse-XXXXX.xml importieren (falls vorhanden)

4. Theme aktivieren → Appearance → Themes → Activate
5. Plugins aktivieren → Plugins → Activate

Nachteil: Manuell, umständlicher als Site Manager Vorteil: Mehr Kontrolle über einzelne 
Komponenten

 Einstellungen optimieren⚙️

Blueprint Creator → Einstellungen

GitHub Repository Einstellungen:

Für automatischen GitHub-Upload: - GitHub User/Organisation → Dein GitHub-Username 
- Repository → Name des Repositories - Branch → z.B. main oder master - Bundle-Pfad → 
Unterordner (z.B. blueprints/ oder leer für Root)

Vorschau: Zeigt generierte Base-URL zum Kopieren

Standard-Optionen:

Blueprint-Erstellung optimieren:
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•  ✅ Theme standardmäßig einschließen → Theme-Checkbox ist beim Start aktiviert

•  ✅WXR-Export standardmäßig einschließen → Post Types (Beiträge & Seiten) sind 
vorausgewählt

Standard-Auswahl für Dropdowns:

Beim Öffnen des Creators vorauswählen:

•  ✅ Aktive Plugins standardmäßig einschließen → Dropdown zeigt “Aktive Plugins” 
statt “Repository Plugins” → Alle aktiven Plugins werden automatisch ausgewählt

•  ✅ Aktives Theme standardmäßig auswählen → Dropdown zeigt “Aktives Theme” 
statt “Kein Theme” → Das aktive Theme ist vorausgewählt

Empfehlung: Für wiederkehrende Aufgaben aktivieren, spart Zeit!

 Typische Workflows📝

Workflow 1: Demo-Site teilen (Lightweight)
Repository-Theme + Repository-Plugins wählen
→ Blueprint generieren
→ Lightweight URL kopieren
→ Per E-Mail/Chat teilen

Workflow 2: Quick Demo mit Test-Posts (Lightweight)
Quick Posts Tab öffnen
→ 2-3 Demo-Posts erstellen
→ Optional: CPT + Taxonomien hinzufügen
→ Blueprint generieren
→ Lightweight URL teilen (ohne Dateien!)

Workflow 3: Custom Post Type präsentieren (Lightweight)
Quick Posts: CPT "portfolio" erstellen
→ Supports: Title, Editor, Thumbnail, Custom Fields
→ Custom Fields: "client", "project_url" hinzufügen
→ 3 Portfolio-Posts erstellen
→ Taxonomie "portfolio_category" mit Terms
→ Blueprint generieren
→ Lightweight URL teilen - CPT sofort verfügbar!

Workflow 4: Custom-Plugin testen (Bundle + Playground Site 
Manager)
Custom Plugin auswählen
→ Bundle erstellen & entpacken
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→ In Playground Site Manager hochladen
→ Blueprint starten & testen

Workflow 5: Custom-Plugin veröffentlichen (Bundle + GitHub)
Custom Plugin auswählen
→ Bundle erstellen
→ Auf GitHub hochladen
→ Playground-Link teilen

Workflow 6: ACF-Setup mit Feldern (Bundle + Bibliothek)
ACF Plugin aus Repository wählen
→ Feldgruppen in Inhalte-Tab auswählen
→ Templates mit ACF-Feldern (FSE-Tab)
→ Bundle erstellen
→ In Bibliothek speichern
→ Via Shortcode auf Demo-Seite zeigen

Workflow 7: Vollständige Site (Bundle + Bibliothek)
Theme + Plugins + Inhalte + Medien wählen
→ FSE Templates & WordPress-Einstellungen hinzufügen
→ Bundle erstellen
→ In Bibliothek speichern
→ Shortcode auf Website einfügen

Workflow 8: Client-Präsentation (Bundle → Playground manuell)
Komplettes Setup erstellen
→ Bundle herunterladen
→ Dateien im Playground manuell hochladen
→ Live-Demo präsentieren

 Tipps & Tricks🔍

Lightweight URL funktioniert nicht?

• Grund: Custom-Plugins/-Themes oder Medien verwendet
• Lösung: Bundle erstellen stattdessen

Bundle zu groß?

• Lösung: Medien reduzieren oder weglassen
• Tipp: Nur notwendige Plugins einschließen

GitHub Upload fehlgeschlagen?

• Prüfen: GitHub Token gültig?
• Prüfen: Repository-URL korrekt?
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• Tipp: Manuell hochladen als Fallback

Playground-Link funktioniert nicht?

• Prüfen: JSON-Syntax korrekt? (im Creator validiert)
• Prüfen: URLs erreichbar?
• Tipp: “Playground öffnen” Button in Bibliothek nutzen

 Feature-Übersicht📊
Feature Lightweight URL Bundle
WordPress.org Plugins ✅ ✅
Custom Plugins ❌ ✅
WordPress.org Themes ✅ ✅
Custom Themes ❌ ✅
Quick Posts ✅ ✅
Custom Post Types ✅ ✅
Custom Taxonomien ✅ ✅
Custom Fields / Metaboxen ✅ ✅
Posts/Pages (WXR)  Begrenzt⚠️ ✅
Medien ❌ ✅
FSE Templates  Begrenzt⚠️ ✅
WordPress-Einstellungen ✅ ✅
Zusätzliche Benutzer ✅ ✅
Repository-Plugins (ACF, 
WooCommerce, etc.)

✅ ✅

Direkt teilbar ✅  (GitHub nötig)❌
URL-Länge Kurz Lang (Datei-Link)
In Bibliothek speicherbar ✅ ✅
Via Shortcode anzeigbar ✅ ✅

 Support🆘
• Autor: Franz Wieser – www.wieser.at 
• Dokumentation: https://www.wieser.at/playground/blueprintcreator
• WordPress Meetup Linz

Version 1.28.0 | Erstellt mit Blueprint Creator für WordPress Playground
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