
Blueprint Creator - Quick Guide

 Quick Start: Lightweight Blueprint (URL only)🚀

For simple blueprints without custom plugins/themes

1. Open Blueprint Creator → WordPress Admin → Blueprint Creator
2. Make your selection:

◦ Theme: Select repository theme (e.g., Twenty Twenty-Four)
◦ Plugins: Select WordPress.org plugins only
◦ Content: Posts/Pages optional

3. Generate Blueprint → Click “Generate Blueprint” button
4. Copy Lightweight URL → The URL appears in the green info box
5. Done! → Share URL or open in Playground

Benefits: No files needed, directly shareable, works instantly

Limitations: Only for WordPress.org themes/plugins, no custom files

Step-by-Step: Create a Lightweight URL

With the Lightweight URL, you can share a complete WordPress test environment (themes, 
plugins, demo content) – no file download needed. Here’s how:

1. Open Blueprint Creator
◦ In the WordPress admin menu, click “Blueprint Creator”.

2. Select a Theme
◦ Choose a WordPress.org theme (e.g., Twenty Twenty-Four). Custom themes are not 

supported for Lightweight URLs.
3. Select Plugins

◦ Enable the desired plugins (only from the WordPress.org repository). Custom plugins 
are not supported for Lightweight URLs.

4. (Optional) Add Quick Posts
◦ In the “Quick Posts” tab, add demo content (title, content, post type, taxonomies, 

etc.).
5. (Optional) Set language, site title, description

◦ Adjust language, site title, and description in the form as needed.
6. Generate Lightweight URL

◦ Click “Generate Blueprint”.
◦ The green “Lightweight URL” box will appear with your ready-to-use URL.

7. Copy the URL
◦ Click the copy icon or “Copy URL” button.

8. Share or open the URL in Playground
◦ The URL can be opened directly in the browser or shared with others.
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Notes: - The Lightweight URL only works with official themes/plugins from WordPress.org. - 
Custom files, plugins, or themes are not included. - The URL is instantly runnable in WordPress 
Playground.

 Quick Posts: Quickly Create Demo Content⚡

For simple test posts without WXR export

What are Quick Posts?

Quick Posts allow you to create demo content directly in the blueprint, without needing a 
complete WXR export. Ideal for: - Quick demos with a few test posts - Plugin presentations 
with sample data - Testing Custom Post Types - Demonstrating taxonomies

Creating Quick Posts:

1. Open Quick Posts Tab → In Blueprint Creator
2. Add Post → Click “Add New Post” button
3. Enter Post Details:

◦ Title: e.g., “My Test Post”
◦ Content: Optional, text or HTML
◦ Post Type:

▪ Default: post (Post)
▪ Or: Create new Custom Post Type (see below)

◦ Custom Fields: Optional, for meta data
◦ Taxonomies: Optional, assign categories/tags

Creating Custom Post Types:

Directly in Quick Posts interface:

1. Open Post Type Dropdown
2. Enter Slug (e.g., event, portfolio, product)
3. Enter Label (e.g., “Event”, “Portfolio”, “Product”)
4. Click “New” Button
5. Select Supports (CPT features):

◦  ✅ Title - Title field
◦  ✅ Editor - Content editor
◦  ✅ Thumbnail - Featured image
◦  ✅ Excerpt - Excerpt
◦  ✅ Custom Fields - Custom fields
◦  ✅ Comments - Comments
◦  ✅ Revisions - Revisions
◦  ✅ Author - Author
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◦  ✅ Page Attributes - Page attributes

The CPT is automatically: - Registered as mu-plugin (customPostType-{slug}.php) - Added 
to blueprint as writeFile step - Available immediately in Playground

Creating Custom Taxonomies:

Taxonomies for CPTs:

1. In a Quick Post → Under “Taxonomies”
2. New Taxonomy → Click “+New Taxonomy” button
3. Enter Taxonomy Slug (e.g., genre, category)
4. Enter Terms (comma-separated, e.g., Action, Drama, Comedy)

The taxonomy is automatically: - Registered as mu-plugin (custom-taxonomy-{slug}.php) - 
Linked to the post type - Terms are assigned to the post

Adding Custom Fields:

Meta data for posts:

1. In a Quick Post → Under “Custom Fields”
2. Add Field → Click “+Add Field” button
3. Field Name (e.g., location, price, date)
4. Field Value (e.g., Vienna, 49.90, 2025-12-25)

With Custom Fields automatically: - A metabox is generated in the CPT (metabox-
{post_type}.php) - Fields are displayed as input fields - Values are saved on save

Example: Event Post with CPT
1. Add Quick Post
2. Post Type: Create "event" (Label: "Event")
3. Supports: Title, Editor, Custom Fields, Revisions
4. Title: "WordPress Meetup Vienna"
5. Custom Fields:
   - location: "Vienna"
   - date: "2025-12-25"
6. Taxonomy: "eventcat" (Terms: "Meetup, WordPress")

Result in Blueprint:
{ 
  "steps": [ 
    {"step": "mkdir", "path": "/wordpress/wp-content/mu-plugins"}, 
    {"step": "writeFile", "path": "customPostType-event.php"}, 
    {"step": "writeFile", "path": "metabox-event.php"}, 
    {"step": "writeFile", "path": "custom-taxonomy-eventcat.php"}, 
    {"step": "runPHP", "code": "wp_insert_post(...) + 
wp_set_post_terms(...)"} 
  ] 
} 
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Advantages of Quick Posts:

 ✅ No WXR export needed - Faster than complete content export
 ✅ Lightweight-compatible - Works in lightweight URLs too
 ✅ CPT & Taxonomies - Automatic registration as mu-plugins
 ✅ Custom Fields - Automatic metabox generation
 ✅ Instantly testable - Available directly in Playground

Limitations:

 ⚠️ For few posts - For many posts, use WXR export instead
 ⚠️ No media - Images/files must be uploaded separately
 ⚠️ Simple structure - For complex relations, use WXR

 Advanced: Bundle Blueprint (with custom files)📦

For blueprints with custom plugins, custom themes or media

Step 1: Create Blueprint

1. Open Blueprint Creator
2. Select custom content:

◦ Theme Tab: Select and activate custom theme
◦ Plugins Tab:

▪ Custom Plugins → Check boxes (auto-exported)
▪ Repository Plugins (e.g., ACF, WooCommerce, Contact Form 7)

◦ Content Tab: Select Posts/Pages/Custom Post Types
◦ Media Tab: Select images/files
◦ FSE Templates Tab:

▪ Templates (page templates)
▪ Template Parts (Header, Footer)
▪ Navigation Menus
▪ Global Styles
▪ Reusable Blocks

◦ Advanced Tab:
▪ WordPress Settings (permalink structure, discussion, etc.)
▪ Create additional users
▪ Run PHP code
▪ WP-CLI commands

Step 2: Create Bundle

3. Generate Blueprint → Click button
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4. Enter Bundle Base URL (optional):
https://github.com/YOUR-USER/YOUR-REPO/blob/main/

5. Create Bundle → Click “Create Bundle” button

6. Bundle ZIP downloads (e.g., blueprint-bundle-1234567890.zip)

 Option A: Upload Bundle to GitHub📤

Prerequisites

• GitHub Account
• Repository created
• GitHub File Uploader Plugin installed (optional)

Method 1: Via Playground Site Manager (recommended for quick 
testing)

1. Unzip Bundle-ZIP (locally on your PC)
2. Open Playground: https://playground.wordpress.net
3. Open Site Manager → Click “Site Manager” in top right
4. Upload Blueprint:

◦ Under “Blueprint” → “Upload Blueprint”
◦ Upload unpacked bundle folder or blueprint.json
◦ Upload all ZIP files (plugins, themes, media)
◦ Upload all XML files (WXR exports)

5. Start Blueprint → Click “Start Site”
6. Done! → Site runs with your blueprint

Benefits: Fast, no GitHub needed, ideal for testing

Method 2: Manual upload to GitHub

1. Unzip Bundle-ZIP (locally on your PC)
2. Open GitHub Repository → Navigate to folder
3. Upload files:

◦ blueprint.json

◦ All .zip files (plugins, themes, media)
◦ All .xml files (WXR exports)

4. Commit → “Upload blueprint files”

Method 3: Automatic (with GitHub Uploader Plugin)

1. Settings → Blueprint Creator → Settings
2. Enter GitHub data:
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◦ User/Organization
◦ Repository
◦ Branch (e.g., main)
◦ Folder (e.g., blueprints/)

3. Enter Bundle URL in Creator
4. Click “Upload to GitHub” button → Done!

Playground Link:
https://playground.wordpress.net/?blueprint-url=https://github.com/USER/
REPO/blob/main/blueprint-bundle-XXXXXXXXXX.zip

 Option B: Save to Library📚

For local management and reuse

Save Blueprint:

1. After blueprint generation:
◦ Click “Save to Library” button

2. Enter title & description
3. Save → Blueprint appears in library

Using Library in Admin:

• Menu: Blueprint Creator → Library
• Overview: All saved blueprints with info boxes:

◦  🔗 Lightweight Blueprint (green) = URL only, no files
◦  📦 Blueprint Bundle (blue) = With custom files

• Actions per blueprint:
◦  🚀 Open Playground → Direct link for testing
◦  📋 Copy Link → URL to clipboard
◦  ⬇️ Download Bundle → Download ZIP file
◦  ✏️ Edit → Change title/description
◦  🗑️ Delete → Remove blueprint

Frontend Shortcode:

On pages/posts:
[blueprint_library] 

What does the shortcode display? - All public blueprints in card layout - Info box: Lightweight 
or Bundle - Button “Open in Playground” - Button “Download Bundle” (if available) - 
Responsive design for all devices

Example usage: - Demo page for clients - Plugin showcase - Present theme templates - Public 
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blueprint collection

 Option C: Upload Bundle Files Individually to Playground🎮

Alternative: Import files manually (without Site Manager)

1. Unzip Bundle-ZIP (locally)
2. Open Playground: https://playground.wordpress.net
3. Upload files:

◦ Plugins: Playground → Plugins → “Add New” → Upload
▪ Upload each plugin .zip individually

◦ Themes: Appearance → Themes → “Add New” → Upload
▪ Upload theme .zip

◦ Media: Media → “Add New” → Upload
▪ Unzip media-XXXXX.zip and upload files

◦ Posts/Pages: Tools → Import → WordPress
▪ Import export-content-XXXXX.xml
▪ Import export-fse-XXXXX.xml (if available)

4. Activate theme → Appearance → Themes → Activate
5. Activate plugins → Plugins → Activate

Disadvantage: Manual, more complex than Site Manager Advantage: More control over 
individual components

 Optimize Settings⚙️

Blueprint Creator → Settings

GitHub Repository Settings:

For automatic GitHub upload: - GitHub User/Organization → Your GitHub username - 
Repository → Repository name - Branch → e.g., main or master - Bundle Path → Subfolder 
(e.g., blueprints/ or empty for root)

Preview: Shows generated base URL for copying

Default Options:

Optimize blueprint creation:

•  ✅ Include theme by default → Theme checkbox is activated on start

•  ✅ Include WXR export by default → Post types (posts & pages) are pre-selected
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Default Selection for Dropdowns:

Pre-select when opening creator:

•  ✅ Include active plugins by default → Dropdown shows “Active Plugins” instead of 
“Repository Plugins” → All active plugins are automatically selected

•  ✅ Select active theme by default → Dropdown shows “Active Theme” instead of “No 
Theme” → The active theme is pre-selected

Recommendation: Enable for recurring tasks, saves time!

 Typical Workflows📝

Workflow 1: Share Demo Site (Lightweight)
Select repository theme + repository plugins
→ Generate blueprint
→ Copy lightweight URL
→ Share via email/chat

Workflow 2: Quick Demo with Test Posts (Lightweight)
Open Quick Posts tab
→ Create 2-3 demo posts
→ Optional: Add CPT + taxonomies
→ Generate blueprint
→ Share lightweight URL (no files needed!)

Workflow 3: Present Custom Post Type (Lightweight)
Quick Posts: Create CPT "portfolio"
→ Supports: Title, Editor, Thumbnail, Custom Fields
→ Custom Fields: "client", "project_url"
→ Create 3 portfolio posts
→ Taxonomy "portfolio_category" with terms
→ Generate blueprint
→ Share lightweight URL - CPT instantly available!

Workflow 4: Test Custom Plugin (Bundle + Playground Site Manager)
Select custom plugin
→ Create & unzip bundle
→ Upload to Playground Site Manager
→ Start blueprint & test

Workflow 5: Publish Custom Plugin (Bundle + GitHub)
Select custom plugin
→ Create bundle
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→ Upload to GitHub
→ Share Playground link

Workflow 6: ACF Setup with Fields (Bundle + Library)
Select ACF plugin from repository
→ Select field groups in Content tab
→ Templates with ACF fields (FSE tab)
→ Create bundle
→ Save to library
→ Display via shortcode on demo page

Workflow 7: Complete Site (Bundle + Library)
Select theme + plugins + content + media
→ Add FSE templates & WordPress settings
→ Create bundle
→ Save to library
→ Insert shortcode on website

Workflow 8: Client Presentation (Bundle → Playground manual)
Create complete setup
→ Download bundle
→ Upload files to Playground manually
→ Present live demo

 Tips & Tricks🔍

Lightweight URL not working?

• Reason: Custom plugins/themes or media used
• Solution: Create bundle instead

Bundle too large?

• Solution: Reduce or omit media
• Tip: Only include necessary plugins

GitHub upload failed?

• Check: GitHub token valid?
• Check: Repository URL correct?
• Tip: Manual upload as fallback

Playground link not working?

• Check: JSON syntax correct? (validated in creator)
• Check: URLs accessible?
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• Tip: Use “Open Playground” button in library

 Feature Overview📊
Feature Lightweight URL Bundle
WordPress.org Plugins ✅ ✅
Custom Plugins ❌ ✅
WordPress.org Themes ✅ ✅
Custom Themes ❌ ✅
Quick Posts ✅ ✅
Custom Post Types ✅ ✅
Custom Taxonomies ✅ ✅
Custom Fields / Metaboxes ✅ ✅
Posts/Pages (WXR)  Limited⚠️ ✅
Media ❌ ✅
FSE Templates  Limited⚠️ ✅
WordPress Settings ✅ ✅
Additional Users ✅ ✅
Repository Plugins (ACF, 
WooCommerce, etc.)

✅ ✅

Directly shareable ✅  (GitHub needed)❌
URL length Short Long (file link)
Save to library ✅ ✅
Display via shortcode ✅ ✅

 Support🆘
• Autor: Franz Wieser – www.wieser.at 
• Dokumentation: https://www.wieser.at/playground/blueprintcreator
• WordPress Meetup Linz

Version 1.28.0 | Created with Blueprint Creator for WordPress Playground
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